Хостинг для Joomla

Требования к хостингу для Joomla

 


Данная статья была написана для Joomla версии 2.5 и на сегодня устарела. Для актуальности информации дополняю её требованиям к програмному обеспечению хостинга для Joomla 3.x.

Требования к хостингу для Joomla 3.x

Требования к хостингу для Joomla необходимо выяснить перед покупкой хостинга. Это особенно актуально для последних версий Joomla 3.5.

  • PHP (Magic Quotes GPC off) 5.6 + or 7 + 5.3.10 +

Поддерживаемые базы данных:

  • MySQL (Требует поддержки InnoDB) 5.5.3 + 5.1 +
  • SQL Server 10.50.1600.1 + 10.50.1600.1 +
  • PostgreSQL 9.1 + 8.3.18 +

Поддерживаемые веб-серверы:

  • Apache (with mod_mysql, mod_xml, and mod_zlib) 2.4 + 2.x +
  • Nginx 1.8 + 1.0 +
  • Microsoft IIS 7 7

Основные требования к хостингу для Joomla 2.5

Во-первых, для удачной установки и правильной работы системы управления сайтом CMS Joomla, хостинг который вы выбираете должен работать с веб сервером Apache или IIS.

Во-вторых, Хостинг должен предоставлять базы данных MySQL (они оптимальны для Joomla). На стороне сервера, язык сценариев должен быть PHP. Язык PHP должен быть с конкретными модулями, которые активируются в PHP для MySQL, XML и Zlib.

Примечания:

  • PHP это скриптовый язык общего назначения;
  • MySQL это свободная система управления базами данных;
  • XML это язык разметки, свод общих синтаксических правил рекомендованный всемирной паутиной;
  • Zlib это свободная библиотека сжатия баз данных.
  • Joomla разработан и испытан в первую очередь на веб-сервере Apache версий 1.3.x + и 2.x +.

По состоянию Joomla версии 1.5.16 также поддерживается Microsoft IIS.Она также будет работать на многих других серверах.
Базы данных MySQL являются предпочтительными для Joomla, но и другие типы баз данных могут работать с необходимой конфигурации, однако не так хорошо. Для работы с базами данных отличных от MySQL требуется серьезные навыки и знания.

Вы должны убедиться, что на хостинге есть и включены в PHP модули XML и Zlib. Включение контролируется в файле php.ini. Если у вас нет доступа к php.ini, то уточните возможность их включения в support хостинг провайдера.

Для Joomla 1.5 (устарело). Не используйте PHP 4.3.9, PHP 4.4.2 и PHP 5.0.4 .Эти версии имеют общеизвестные ошибки, которые будут мешать во время установке CMS Joomla. Были также проблемы с версией Zend Optimizer 2.5.10 для PHP 4.4.x. Выбирайте хостинг с более поздними версиями PHP.

Внимание! CMS Joomla не поддерживает базы данных MySQL 6.x. (версия шесть).

CMS Joomla была успешно протестирована во многих вариантах в рамках трех основных операционных систем, ОС Windows, Linux, Apple Mac OSX. Joomla вполне может работать и на других платформах, но это официально не подтверждено Joomla.

Joomla также используются и регулярно испытываются через основные веб-браузеры. Сайты, сделанные при помощи Joomla доступны для IE6 +, Firefox 1.5 +, Safari ,Опера,Chrome и других. По документам Joomla были известны проблемы с IE6.Не работали некоторые CSS параметры дисплея в шаблоне презентации, и это следует иметь в виду.

  • Для версиии Joomla 3.0, 3.1 и 3.2 хостинг должен должен удовлетворять следующим требованиям: PHP 5.3.1+ (Magic Quotes GPC off), MySQL 5.1+ (с поддержкой InnoDB), Apache 2.x+ (с модулями mod_mysql, mod_xml, и mod_zlib).
  • Для версии Joomla 3.3.x уже нужен PHP от 5.3.10, лучше сразу установить PHP 5.4, чтобы не менять PHP при выходе Jommla 3.4.
  • Для последних версий Joomla 3.4+ лучший вариант по скорости показывает PHP 7 версии

На этом о требованиях к хостингу для Joomla все!

©Joomla-abc.ru

Статьи близкие по теме

Популярные статьи сайта

 

 

 

Компонент Sh404